Системные требования: COMSOL Multiphysics® 6.0

Общие требования для всех операционных систем:

  • Интернет-подключение в процессе установки.
  • Не менее 4 ГБ оперативной памяти.
  • От 2 до 13 ГБ свободного места на диске, в зависимости от параметров установки.
  • Adobe® Acrobat® для просмотра и печати PDF-файлов документации COMSOL.
  • 64-разрядный процессор Intel® или AMD® на базе архитектуры Intel® 64 или AMD64 с набором команд SSE4. Этому требованию удовлетворяют процессоры Intel®, выпущенные не ранее 2009 года, и процессоры AMD®, выпущенные не ранее 2012 года. На компьютерах macOS 11 и 12 поддерживаются процессоры M1 (и более поздние).

Более подробные рекомендации по выбору оборудования приведены в базе знаний.

Требования к операционным системам

См. также перечень системных требований модулей интеграции, в котором приведены специфические условия работы модуля «CAD-импорт», модуля «CAD-импорт и CAD-операции» и модулей группы LiveLink™ для CAD. Системные требования COMSOL Compiler™ идентичны системным требованиям COMSOL Multiphysics®.

Windows® macOS Linux®
64-разрядные операционные системы
  • Windows® 11
  • Windows® 10
  • Windows® 10 Pro for Workstations
  • Windows® 8.1
  • Windows® 7 SP11
  • Windows Server® 2022
  • Windows Server® 2019
  • Windows Server® 2016
  • Windows Server® 2012 R2
  • macOS 10.14, 10.15, 11.0 и 12 (процессоры Intel)
  • macOS 11 и 12 (процессоры M1)
  • Debian® 9, 10 и 11
  • Red Hat® Enterprise Linux® 7.9 и 8.5
  • CentOS® 7.9 и 8.5
  • Rocky Linux 8.5
  • Oracle® Linux® 8.5
  • Ubuntu® 18.04 и 20.04
  • SUSE® Linux Enterprise Desktop® 15 SP3
  • OpenSUSE® Leap 15.2 и 15.3
1Требуется .Net 4.5.1.

Специфические системные требования

Linux®
  • Библиотека GNU C 2.17 или более поздней версии
  • Linux® ядро 3.10 или более поздняя версия
  • Для работы менеджера лицензий FlexNet® требуется Linux Standard Base (LSB™)1

1 См. также «Менеджер лицензий FlexNet® на Linux®» ниже.

Справочная система на Linux®

Для правильной работы справочной системы в операционной системе Linux® необходимо установить следующие программные пакеты:

Операционная система Название пакета
Debian® 9, 10 и 11 libwebkit2gtk-4.0-37
Ubuntu® 18.04 и 20.04 libwebkit2gtk-4.0-37
Red Hat® Enterprise Linux® 7 и CentOS® 7 webkitgtk4
Red Hat® Enterprise Linux® 8, CentOS® 8 и Oracle® Linux 8 webkit2gtk3
SUSE® Linux Enterprise Desktop® 15 SP3 libwebkit2gtk-4_0-37
OpenSUSE® Leap 15.2 и 15.3 libwebkit2gtk-4_0-37

Менеджер лицензий FlexNet®

Системные требования менеджера лицензий идентичны системным требованиям COMSOL Multiphysics®. COMSOL 6.0 в общем случае не совместим с версиями менеджера лицензий FlexNet® из предыдущих релизов COMSOL. При обновлении COMSOL до версии 6.0 необходимо также обновить менеджер лицензий. В COMSOL 6.0 используется FlexNet® версии 11.18.1. Версия lmgrd должна соответствовать версии FlexNet®, используемой программным обеспечением COMSOL®.

Менеджер лицензий FlexNet® на Linux®

На сервере лицензий под управлением операционной системы Linux® должен быть установлен Linux Standard Base (LSB™).

Если основной пакет LSB™ отсутствует в репозитории дистрибутивов, самостоятельно создайте символьную ссылку с правами доступа root:

ln -s /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3

Дистрибутив Требуемые пакеты
Debian® lsb-core
Ubuntu® lsb-core
Red Hat® redhat-lsb
SUSE® lsb

Среда разработки приложений

Работа среды разработки приложений поддерживается только в операционных системах Windows®.

Система администрирования моделей

Возможность использования локальной версии системы администрирования моделей включена во все типы лицензий, за исключением лицензии для учебного класса (CKL). Локальная база данных системы администрирования моделей должна быть расположена непосредственно на вашем компьютере, базу данных нельзя перенести на сетевой или облачный диск. Установка и подключение централизованной системы Model Manager server возможна в рамках сетевой плавающей лицензии (FNL).

Надстройка Microsoft® PowerPoint®

Надстройка COMSOL для PowerPoint® совместима в PowerPoint® 2010, 2013, 2016 и 2019 и 2021 в операционных системах Windows®. PowerPoint® 2010 Starter не поддерживается. При использовании Office 365 на ПК необходимо установить PowerPoint®, поскольку для работы надстройки требуется версия PowerPoint® с поддержкой VSTO.

Требования для параллельных вычислений

Windows® macOS Linux®
Системы с общей памятью Все поддерживаемые версии Windows® Все поддерживаемые версии macOS Все поддерживаемые дистрибутивы Linux®
Системы с распределённой памятью
  • Windows Server® 20221
  • Windows Server® 20191
  • Windows Server® 20161
  • Windows Server® 2012 R21
Не поддерживается
  • Red Hat® Enterprise Linux® 7.9 и 8.5
  • CentOS® 7.9 и 8.5
  • Debian® 9 и 10
  • Ubuntu® 18.04 и 20.04

Все компьютеры в кластере должны использовать одинаковые версии Linux® и иметь идентичное оборудование. Рекомендуется установить OpenFabrics Enterprise Distribution (OFED) версии 1.5.0 или выше. Если вы используете сетевые системы с поддержкой RDMA, требуется драйвер или библиотека, совместимые с DAPL версии 1.2 или выше. Данное программное обеспечение обычно поставляется с оборудованием.

1 Требуется Windows HPC Pack для соответствующей версии Windows Server.

COMSOL Multiphysics® 6.0 прошёл проверку на системах, совместимых со спецификацией Intel HPC Platform, поэтому обеспечивается совместимость с избранными системами для моделирования Intel® Select Solutions for Simulation and Modeling.

Чтобы узнать о том, как можно запустить COMSOL Multiphysics® и COMSOL Server™ в облаке, просмотрите данную страницу.

Официально поддерживаемые компиляторы

В COMSOL Multiphysics® предусмотрены внешние C-интерфейсы для внешних функций, внешних моделей материалов и внешних динамических С-библиотек в среде разработки приложений.

Windows® macOS Linux®
Внешние C-интерфейсы Microsoft Visual Studio® 2017 Официально поддерживается Intel® Parallel Studio XE Composer Edition для C++ в ОС macOS 20.4 (также известен как Intel® C++ Compiler версии 19.1.3.301) с Apple LLVM версии 11.0.3 (clang-1103.0.32.62) Официально поддерживается Intel® Parallel Studio XE Composer Edition для C++ Linux® 20.4 (также известен как Intel® C++ Compiler версии 19.1.3.304) с GCC 6.5.0
Java® API JDK 8 и 11 JDK 8 и 11 JDK 8 и 11

COMSOL Multiphysics® разрабатывается и тестируется с использованием перечисленных выше компиляторов C/C++. Обратите внимание, что более поздние версии этих компиляторов C/C++ также могут быть совместимы с внешними C-интерфейсами. При использовании COMSOL API с Java® API в режиме клиент/сервер с jar-файлами, перечисленными в документе <installation dir>/bin/comsolclientpath.txt, поддерживаются JRE 8 и JRE 11. При использовании COMSOL API с Java® API в автономном режиме с jar-файлами, перечисленными в документе <installation dir>/bin/comsolpath.txt, поддерживается JRE 11.

Среда разработки Java

COMSOL поставляется вместе с OpenJDK 11.0.13. В качестве альтернативы в процессе установки можно выбрать Java 11 версии 11.0.9.1 или новее.

Требования к графической системе

COMSOL рекомендует использовать аппаратный рендеринг для повышения производительности. Для аппаратного рендеринга необходимы драйверы, поддерживающие OpenGL® версии 2.1 или новее. Пользователи Windows® также могут использовать DirectX® версии 9.

Для использования опции оптимизации качества Optimize for Quality в окне настройки графики Graphics рекомендуется иметь не менее 2 Гб графической памяти.

AMD®

Windows® 11

Модель карты Версия драйвера
AMD Radeon™ Pro W6800 21.10.3
AMD Radeon™ Pro W6600 21.10.3
AMD Radeon™ Pro W5700 21.10.3
AMD Radeon™ Pro W5500 21.10.3
AMD Radeon™ Pro VII 21.10.3
AMD Radeon™ Pro WX 9100 21.10.3
AMD Radeon™ Pro WX 8200 21.10.3

Windows® 10

Модель карты Версия драйвера
AMD Radeon™ Pro WX 7100 21.Q3
AMD Radeon™ Pro WX 5100 21.Q3
AMD Radeon™ Pro WX 4100 21.Q3
AMD Radeon™ Pro WX 3200 21.Q3
AMD Radeon™ Pro WX 3100 21.Q3
AMD Radeon™ Pro WX 2100 21.Q3

Ubuntu® 20.04

Модель карты Версия драйвера
AMD Radeon™ Pro W6800 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro W6600 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro W5700 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro W5500 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro VII AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro WX 9100 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro WX 8200 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro WX 7100 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro WX 5100 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro WX 4100 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro WX 3200 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro WX 3100 AMDGPU (Linux® 5.11.0)
AMD Radeon™ Pro WX 2100 AMDGPU (Linux® 5.11.0)

Ubuntu® 18.04

Модель карты Версия драйвера
AMD Radeon™ Pro WX 3100 AMDGPU (Linux® 5.4.0)

NVIDIA®

Windows® 11

Модель карты Версия драйвера
Quadro® RTX A5000 472.12
Quadro® RTX A4000 472.12
Quadro® RTX A2000 472.12
Quadro® RTX 6000 472.12
Quadro® RTX 4000 472.12
Quadro® P4000 472.12
Quadro® P3200 472.12
Quadro® P2000 472.12
Quadro® P1000 472.12
Quadro® P600 472.12
Quadro® P400 472.12

Windows® 10

Модель карты Версия драйвера
Quadro® RTX 3000 452.06
Quadro® T1000 452.06

Перечисленные выше графические карты прошли тщательное тестирование на совместимость с программным обеспечением COMSOL Multiphysics®. Обратите внимание, что другие графические карты AMD® или NVIDIA® также могут быть совместимы с COMSOL Multiphysics®. Вероятнее всего, с COMSOL Multiphysics® будут совместимы карты, имеющие те же модельные серии, что и указанные выше модели.

Для обеспечения аппаратного ускорения на Linux® используйте проприетарные драйверы производителей графических карт, таких как NVIDIA®. В противном случае используйте программный рендеринг COMSOL®. Видеодрайвер Nouveau может использоваться только для программного рендеринга.

Примечание. Представленная на этой странице информация является справочной. Следование рекомендациям не избавляет от необходимости изучения и подбора оптимальной конфигурации оборудования в конкретных условиях использования COMSOL® или иного программного обеспечения. Вычислительные системы и оборудование постоянно обновляется и совершенствуется, поэтому выбор подходящего для ваших задач оборудования может меняться.

Adobe и Acrobat являются зарегистрированными товарными знаками или товарными знаками компании Adobe Systems Incorporated в США и (или) других странах. AMD, AMD Athlon, FirePro и Radeon являются товарными знаками или зарегистрированными товарными знаками компании Advanced Micro Devices, Inc. Debian является зарегистрированным товарным знаком компании Software in the Public Interest, Inc. в США. FlexNet является зарегистрированным товарным знаком компании Flexera Software LLC. NVIDIA и NVIDIA Quadro являются зарегистрированными товарными знаками компании NVIDIA Corporation в США и (или) других странах. Intel и Pentium являются товарными знаками компании Intel Corporation или ее дочерних компаний в США и (или) других странах. Oracle и Java являются зарегистрированными товарными знаками компании Oracle и (или) ее дочерних компаний. Red Hat, Red Hat Enterprise Linux и CentOS являются зарегистрированными товарными знаками компании Red Hat, Inc. Ubuntu является зарегистрированным товарным знаком компании Canonical Ltd. OpenGL является товарным знаком или зарегистрированным товарным знаком компании Silicon Graphics, Inc. в США и (или) других странах мира. OpenSUSE и SUSE являются зарегистрированными товарными знаками компании SUSE LLC. Linux, Linux Standard Base и LSB являются товарными знаками или зарегистрированными товарными знаками Линуса Торвальдса (Linus Torvalds) в США и других странах. MacOS является товарным знаком компании Apple Inc. в США и других странах. Microsoft, DirectX, PowerPoint, Visual Studio, Windows и Windows Server являются зарегистрированными товарными знаками или товарными знаками компании Microsoft Corporation в США и (или) других странах. Компания COMSOL AB, а также ее дочерние компании и продукция не связаны, не рекомендовались, не финансировались и не поддерживались владельцами данных товарных знаков.